[FFmpeg-user] How to build and run ffplay on MacOSX

Symadept symadept at gmail.com
Tue Jun 5 09:22:03 CEST 2012

I am looking to build and run ffplay on MacOSX. Can any one point me some
specific steps on this?

So far I downloaded SDL source
zip<http://www.libsdl.org/release/SDL-1.2.15.zip>and ran following
commands on the SDL-1.2.15
sudo make install
Everything was successful.

I am struck how to move further.
I tried to run ./configure, it throws the error,

:ffplay mshaik$ ./configure
yasm not found, use --disable-yasm for a crippled build

If you think configure made a mistake, make sure you are using the latest
version from Git.  If the latest version fails, report the problem to the
ffmpeg-user at ffmpeg.org mailing list or IRC #ffmpeg on irc.freenode.net.
Include the log file "config.log" produced by configure as this will help
solving the problem.

Then tried to use ./configure --disable-yasm then it ends up with warning:
License: LGPL version 2.1 or later
Creating config.mak and config.h...

WARNING: pkg-config not found, library detection may fail.

What does it mean? How can I build and run ffplay and see it playing some
video file.

Thanks in advance.


More information about the ffmpeg-user mailing list