[FFmpeg-user] problem with audio/video sync after conversion

Arlo Leach lists at arlomedia.com
Mon Jun 25 23:07:33 CEST 2012


Thanks for the suggestions. I've worked through them all:

> Have you tried with 44Khz audio?

I've tried 22050, 44100 and 48000 ... same result.

> http://www.dvxuser.com/V6/showthread.php?214956-mp4-renders-4-frames-out-of-sync
> use "CBR instead of VBR" (not sure what libfaac uses).

A four-frame delay in the picture is about what I'm seeing, but that thread describes a problem playing back in QuickTime and my QuickTime playback is fine; only Flash playback is out of sync. Anyway, I've tried both CBR and VBR  in the source video, with the same result.

> Maybe try another aac codec?

Do you mean instead of libfaac? Can you suggest an alternative?

I did notice that I'm still running the CentOS default version of libfaac, 1.26. I spent a couple hours trying to install the latest version, but was not able to get past this discrepancy:


I couldn't get a newer version of mp4v2 to compile, and I couldn't get libfaac to compile without mp4v2 (I tried -disable-mp4v2 and --with-mp4v2=no).

> maybe a different version of flash player:

I actually had an older Flash 10.x plug-in installed on my computer, then updated to the latest 11.x version with the same result.

> and "add white noise" http://forums.creativecow.net/thread/3/911682

I don't think this is my problem because my audio is out of sync consistently throughout the video. Also, one of my videos already has noticeable background noise that should prevent any "collapsing" of silent segments.


If I remove -r 15 from my ffmpeg conversion command, and let the converted video retain its original frame rate of 29.97, the sync problem disappears. I was using -r 15 to make my converted file sizes smaller. I could just remove this since I'm capping the bit rate anyway, but does this help reveal what the problem is?



Arlo Leach

More information about the ffmpeg-user mailing list