[FFmpeg-user] Problems Converting JPEG Image Files to MPEG Movie file

Brent L. Bates blbates at vigyan.com
Wed May 2 20:58:20 CEST 2012

     I've been working on this for about a week now.  I've read the manuals
and done some Googling, but just can not figure out what I'm doing wrong.
It is probably something obvious I'm missing.  I have over 15,000 jpg files
I want to combine into a single mpeg movie file and everything I've tried
fails.  If I try to process all the files I get a `Segmentation fault'.
If I try to process 100 files or more I get an error message and no output
file.  If I process 99 or less files, I get my output file fine.  My basic
command is:

	ffmpeg -i *.jpg out.mpeg

The above command works for < 99 image files.  The moment I add one more file,
I get:

	"Error while opening encoder for output stream #0.0 - maybe
	 incorrect parameters such as bit_rate, rate, width or height"

I get the above error from 100 to 118 files.  With 119, I get the
`Segmentation fault'.  This is the end of the output:

	Input #0, image2, from '2012041200010001.jpg':
	  Duration: 00:00:00.04, start: 0.000000, bitrate: N/A
	    Stream #0.0, 1, 1/25: Video: mjpeg, yuvj422p, 320x240, 1/25,
	       25 tbr, 25 tbn, 25 tbc
	Segmentation fault

I'm running under Scientific Linux 5.7, a Red Hat rebuild.
ffmpeg version is 0.6.5  This is the most recent RPM build I've found.
The system has 4GB memory and 16GB swap.  I've used the `limit' command
to put all my resources to `unlimited', except for descriptors=1024 and
maxproc=36864.  The last 2 are the defaults and seem reasonable.  I'm under
a time crunch so any help would be greatly apreciated.  Thanks.

More information about the ffmpeg-user mailing list