[FFmpeg-user] Problem opening (mov, mp4, 3gp) with avformat_open_input

mastereve gheorghitacristian at mac.com
Tue Jan 14 13:49:26 CET 2014

I have a simple program that opens a video file. (http://pastebin.ca/2537968)

Avi and other formats work but when it comes to mov, mp4 and 3gp it gives
the error "moov atom not found". I have tried different mp4's and mov files
but I get the same error.

I also tried with ffmpeg command line and it worked, so I am sure that the
files I am testing are not missing the moov atom.

Upon further inspection I found where the code tests for the moov atom and
by debugging I found out that MOVContext variable *mov is NULL even after it
was initialised with the AVFormatContext. (see here

I am pretty much stuck at this moment and I don't know what I am missing.

View this message in context: http://ffmpeg-users.933282.n4.nabble.com/Problem-opening-mov-mp4-3gp-with-avformat-open-input-tp4663219.html
Sent from the FFmpeg-users mailing list archive at Nabble.com.

More information about the ffmpeg-user mailing list