[FFmpeg-user] Questions about w3fdif deinterlacing

Seth Parker csparker247 at gmail.com
Thu Jan 16 22:17:27 CET 2014

So after looking at my sample a little closer, ffmpeg detects a 29.97 fps
input but sets output to 59.94. I just wasn't looking at the input closely
enough yesterday. Still, I'm getting the same issue.

Here's a zip with the sample as well as some tests I ran:

I ran three commands on the sample:
ffmpeg -i sample.mov -c:v libx264 -pix_fmt yuv420p -vf "w3fdif"
ffmpeg -i sample.mov -c:v libx264 -pix_fmt yuv420p -vf "idet, w3fdif"
ffmpeg -i sample.mov -c:v libx264 -pix_fmt yuv420p -r 29.97 -vf "w3fdif"

Am I just ignorant of how all of this is working?

*Seth Parker*
Video Editor | The University of Kentucky Vis Center
www.csethparker.com | www.vis.uky.edu

On Thu, Jan 16, 2014 at 3:54 PM, Carl Eugen Hoyos <cehoyos at ag.or.at> wrote:

> Seth Parker <csparker247 <at> gmail.com> writes:
> > This also confirms how I thought idet works: it reads
> > the whole stream and just reports what it detected.
> (It reads as much as you let it read.)
> I don't think anything else makes sense...
> > That choppiness with my 59.94 footage is still strange,
> > though...
> Please provide a sample.
> Carl Eugen
> _______________________________________________
> ffmpeg-user mailing list
> ffmpeg-user at ffmpeg.org
> http://ffmpeg.org/mailman/listinfo/ffmpeg-user

More information about the ffmpeg-user mailing list