[FFmpeg-user] avfoundation on osx 10.7.5: issues with audio input

John Robinson jrobinsonmedia at gmail.com
Wed Mar 4 20:45:30 CET 2015

Thanks Thilo -
I'm trying to apply the patches, but I just joined the list recently so don't have the actual emails. I'm trying to copy the patches from the emails but there are a few in that thread, none of which are getting past 'git apply' for me.  One of them looks quite promising though. I may attempt to apply manually but I'd much rather apply the patch directly.

Thanks again,

On Mar 4, 2015, at 12:23 PM, Thilo Borgmann <thilo.borgmann at mail.de> wrote:

> Hi,
>> [...]
>> As a side note, I've modified 'configure' . I've removed the
>> -framework CoreGraphics bits since ffmpeg wouldn't compile with those
>> bits included. I also tried changing it to ApplicationServices which
>> compiled, but resulted in the same 'audio format is not supported'
>> error when I tried to capture audio. Anyone have any thoughts? I
>> don't know enough objective-C to modify avfoundation.m to give a more
>> descriptive error message but if anyone wants to point me in the
>> right direction I'll gladly give it a whirl and try to capture any
>> more details as to what's going wrong.
> please apply both patches posted from Carl Eugen in this mail:
> http://thread.gmane.org/gmane.comp.video.ffmpeg.devel/188519/focus=189535
> They might already solve both of your problems and will hit git HEAD soon.
> If you still have issues with both patches applied, please open a ticket
> on trac.ffmpeg.org.
> -Thilo
> _______________________________________________
> ffmpeg-user mailing list
> ffmpeg-user at ffmpeg.org
> http://ffmpeg.org/mailman/listinfo/ffmpeg-user

More information about the ffmpeg-user mailing list