[FFmpeg-user] distorted video while uploading mp4 file over RTSP using ffmpeg.exe

Lalit Patil lalit.patil005 at gmail.com
Wed Jan 6 11:36:29 CET 2016

Dear All,

I am getting a distorted video when uploading a mp4 file to wowza server
over rtsp, also I am not getting video quality as original video.

My Wowza server is on different machine.

my command is :

ffmpeg.exe -re -i input.mp4 -vcodec libx264 -vprofile high -r 24 -g 48 -vb
150000 -strict experimental -acodec aac -ab 96000 -ar 48000 -ac 2 -f rtsp
rtsp://[server address]:[port]/live/output

i have tried the above command with below options also.
-qp 0 without -vprofile
-crf 22,
-crf 0 ,
-target ntsc-dvd,
-bufsize 64k -minrate 344k -maxrate 400k
-bufsize 1835k -minrate 344k -maxrate 400k

but still not getting the original video quality,

If I use the above command on the server itself then the video is correct.
But this does not serve my purpose.

Can someone Please help me with this as it is urgent, As we are almost on
the verge of stopping the use of FFMPEG EXE as it is not serving our

thanks in advance,


*Thanks and Regards,**Lalit Patil*

More information about the ffmpeg-user mailing list