[FFmpeg-user] FFMPEG fails 5% responding to SIGTERM and SIGINT

Osama Alshaykh osama at nxtec-corp.com
Thu Feb 9 18:04:32 EET 2017

I apologize I forgot to include the command we use:

ffmpeg -y \
    -f x11grab -r $RATE -s $RESOLUTION -thread_queue_size $QUEUE_SIZE -i :$DISPLAY.0+0,0 \
    -f alsa -thread_queue_size $QUEUE_SIZE -i plug:asnoop$DISPLAY -acodec libfdk_aac -ar 44100 \
    -c:v libx264 -preset $PRESET -pix_fmt yuv420p -r $RATE \
    -crf 28 -g 120 -keyint_min 5 -tune zerolatency -threads 1 \
    -f mp4 $OUTPUT > /tmp/jibri-ffmpeg-$DISPLAY.out 2>&1 &

Thank you,

> On Feb 9, 2017, at 11:02 AM, Osama Alshaykh <osama at nxtec-corp.com> wrote:
> Hi Everyone,
> I am a big fan of FFMPEG from my days in video standards.  We are using FFMPEG on debian Linux.  We are using it to capture screens using x11grab and also using alsa to capture audio.  
> I found, what I can't always stop ffmpeg even I have its pid.  we tried SIGTERM and we also tried sending SIGINT, but sometimes it doesn't work.   In 5% of the FFMPEG sessions, it fails to stop.
> In these cases we can only stop ffmpeg only by SIGKILL, but video file is not correct after sending SIGKILL (doesn't have end-header). Any ideas or suggestions will be greatly appreciate.
> Thanks,
> Osama Alshaykh
> _______________________________________________
> ffmpeg-user mailing list
> ffmpeg-user at ffmpeg.org
> http://ffmpeg.org/mailman/listinfo/ffmpeg-user
> To unsubscribe, visit link above, or email
> ffmpeg-user-request at ffmpeg.org with subject "unsubscribe".

More information about the ffmpeg-user mailing list