[FFmpeg-user] Problems playing mjpeg stream at different bitrates

Fabian Kurt fabian.kurt at tomtom-tools.com
Mon Sep 17 14:46:59 EEST 2018


> Do the streams really work with other players?

Yes, we tested our application for several months with a built-in VLC player and it worked well.
VLC needs several attempts to start playing the stream but then it works fine.
I noticed that FFplay has less delay than VLC. This was the reason to change.

Fabian Kurt

-----Urspr√ľngliche Nachricht-----
Von: ffmpeg-user [mailto:ffmpeg-user-bounces at ffmpeg.org] Im Auftrag von Carl Eugen Hoyos
Gesendet: Montag, 17. September 2018 12:54
An: FFmpeg user questions <ffmpeg-user at ffmpeg.org>
Betreff: Re: [FFmpeg-user] Problems playing mjpeg stream at different bitrates

2018-09-17 11:30 GMT+02:00, Fabian Kurt <fabian.kurt at tomtom-tools.com>:

> FFPlay is often not able to decode the stream. If we configure higher 
> bitrates of the camera output, FFplay is more often able to decode it 
> but not always. At lower bitrates <6Mbit/s it's mostly impossible to decode.
> The main error occurring is: "No JPEG data found in image".

This may not be the only problem but afaict the COM marker has a stored length that is always longer than the whole image.
Not sure how this can be reliably detected in a mjpeg stream / FFmpeg does read the single images if you extract them.

Do the streams really work with other players?

Carl Eugen
_______________________________________________
ffmpeg-user mailing list
ffmpeg-user at ffmpeg.org
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email ffmpeg-user-request at ffmpeg.org with subject "unsubscribe".



More information about the ffmpeg-user mailing list