[FFmpeg-user] Multiple FFMpeg-Cuda-HLS-Transcoding Instances -> Deadlock Behavior

Marco Kittel marcokittel at web.de
Mon May 4 11:22:19 EEST 2020


i'm having a hard time rendering multiple hls instances with nvidia
gear. The details are in the forum post. Here is a little summary.
Everytime without any exception, when i'm running multiple instances of
ffmpeg with cuda support, all instrances until one instance are stopping
to work. It looks like a deadlock. Because this behavior isn't happening
when i'm using libx264, i asked nvidia - how to fix it. I made a youtube
video for you guys to see whats happening.

I tried every new nvidia driver and the beavior was the same. Then i
build ffmpeg again with gcc 8, still the same behavior. I will try to
rebuild ffmpeg with gcc 7.


How did i build ffmpeg:

./configure --enable-libx264 --enable-cuvid --enable-gpl --enable-libnpp
--enable-cuda --disable-cuda-sdk --enable-nonfree
--extra-ldflags=-L/usr/local/cuda-10.2/lib64 && make -j 8

How i'm executing ffmpeg:

-vsync 0
-loglevel debug
-threads:v 1
-threads:a 1
-filter_threads 1
-thread_queue_size 1024
-hwaccel cuda
-hwaccel_device 0
-hwaccel_output_format cuda
-deint adaptive
-g 50 -sc_threshold 0
-map [wide360p]
-preset medium
-c:v:0 h264_nvenc
-preset fast
-profile:v baseline
-b:v:0 600k
-bufsize 24k
-minrate 400k -maxrate 600k
-map [480p]
-c:v:1 h264_nvenc
-preset medium
-profile:v baseline
-b:v:1 1000k
-bufsize 56k
-minrate 800k -maxrate 1600k
-preset fast
-map [source]
-c:v:2 h264_nvenc
-preset medium
-profile:v baseline
-preset fast
-b:v:2 3600k
-minrate 2000k -maxrate 4000k
-bufsize 144k
-map [240p]
-c:v:3 h264_nvenc
-preset medium
-profile:v baseline
-zerolatency 1
-preset fast
-b:v:3 400k
-bufsize 16k
-map a:0
-c:a aac
-b:a 128k
-ac 2
-map a:1
-c:a aac
-b:a 96k
-ac 2
-f hls
-hls_time 4
-hls_list_size 0
-hls_flags append_list
-hls_allow_cache 0
-hls_playlist_type event
-master_pl_name $MASTER_PLAYLIST_NAME
-var_stream_map “a:0,agroup:audio,default:yes,language:DEU
a:1,agroup:audio,language:FR v:0,agroup:audio v:1,agroup:audio,
v:2,agroup:audio, v:3,agroup:audio”

Please help me to fix this behavior.

Best regards

Marco Kittel

-------------- next part --------------
A non-text attachment was scrubbed...
Name: pEpkey.asc
Type: application/pgp-keys
Size: 1761 bytes
Desc: not available
URL: <https://ffmpeg.org/pipermail/ffmpeg-user/attachments/20200504/b6825b27/attachment.key>

More information about the ffmpeg-user mailing list