[Libav-user] Decoding an AAC-LATM 5.1 audio returns errors and only 1 channel with data

Nicolás Dato ndato at 3way.com.ar
Wed Jan 9 01:05:21 CET 2013

> I understand.
> Please provide a longer sample (a few seconds 5.1 if possible
> and at least additional 10 seconds).

I tried to attach a bigger file but the list doesn't allow more than
40k, so here is a 400k (17 seconds) file:
The first 11 frames are ok, and you can hear something

I have more info:
Using ffmpeg 0.10 and ffprobe -show_frames I could find out that the
'channel element 0.2 is not allocated' appears every 11 frames all the
time (so I cannot generate a file with more than 11 frames in 5.1)
(but as I said, with 0.10 the output keeps in 5.1 after all and seems
Using ffmpeg 1.1, and playing with ffplay the error appears only once,
and after that the channels are 'muted', but using my own
implementation the error repeats forever.

I downloaded FAAD and tried decoding the file, but it says:
Error: Channel coupling not yet implemented

I think I should also report this as a bug. The audio is from an
Argentinian Digital TV transmission, which is not fully implemented
here and the transmissions are changing every time, so there is a
chance that the audio itself is corrupted.


More information about the Libav-user mailing list