[Libav-user] IP cam accessing directly and from dshow speeddifferences.

Matthew Einhorn moiein2000 at gmail.com
Thu Jun 20 01:20:51 CEST 2013

On Wed, Jun 19, 2013 at 6:51 PM, Andrey Utkin <
andrey.krieger.utkin at gmail.com> wrote:

> 2013/6/20 Matthew Einhorn <moiein2000 at gmail.com>:
> > When I tried wgets on the link I get a 27 byte file (attached).
> Did you look into it?
_red in the face_  I just assumed it'd be binary data. I'll know nexttime
to at least open the file with notepad.

I did it again properly with wgets which downloaded the actual video now.
When I open the file in notepad I see this sequence repeatedly:
Content-Type: image/jpeg
Content-Length: 38416
followed after a newline with binary data.

calling ffplay on this "ffplay -loglevel debug -analyzeduration 9999999
-probesize 9999999 videostream.cgi"

I still get this:
[ingenient @ 00000000025ea480] Format ingenient probed with size=2048 and
File position before avformat_find_stream_info() is 0    0B f=0/0
[ingenient @ 00000000025ea480] Could not find codec parameters for stream 0
(Video: mjpeg): unspecified size
Consider increasing the value for the 'analyzeduration' and 'probesize'
[ingenient @ 00000000025ea480] File position after
avformat_find_stream_info() is 4
C:\FFmpeg\videostream.cgi: could not find codec parameters
[AVIOContext @ 00000000025e9ec0] Statistics: 32768 bytes read, 0 seeks

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://ffmpeg.org/pipermail/libav-user/attachments/20130619/2551acc6/attachment.html>

More information about the Libav-user mailing list