[Libav-user] Reading from IP Camera (RTSP) using FFmpeg results in 5xx Server Error

black copper blackcopper1 at gmail.com
Wed Dec 9 10:16:54 CET 2015

I have a scenario where I am trying to read from IP camera using RTSP

On my development PC everything is working fine (rtsp url is something
like: rtsp://admin:12345@, but when I try to test it over a
friend's place, he has different camera (Axis IP camera), and the url fails
to open.

self generated log is something like:

Error: avformat_open_input()
error message: Server returned 5XX Server Error reply

I tried opening it using HTTP tunneling, but this time I'm getting a
different error:

error message: Error number -5 occurred

The latter error message even appears on my dev PC (just to mention that I
tried this as well); so HTTP tunnel is no good.

Any one knows how to fix 5XX Server Error?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://ffmpeg.org/pipermail/libav-user/attachments/20151209/a3bc7dec/attachment.html>

More information about the Libav-user mailing list