[Libav-user] Encoders not working (Even using transcoding.c example)

M N assemblerx86 at yandex.com
Wed Sep 7 23:40:47 EEST 2016


 I have been getting errors regarding encoders such as: "Tag avc1/ incompatible with output codec id '28'" while trying to encode anything, I also get errors such as "Invalid data detected in input" while trying to use avformat_write_header(). I am using latest FFMPEG Dev and Shared. And YES, I have tried many other videos.

 So I have tried compiling "transcoding.c" ffmpeg example, and I could compile it, but when I tested it, I get this error:

>testffc vid.mp4 vid3.mp4
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from 'vid.mp4':
    major_brand     : mp42
    minor_version   : 0
    compatible_brands: isommp42
    creation_time   : 2012-11-25T22:19:36.000000Z
  Duration: 00:03:51.80, start: 0.000000, bitrate: 1023 kb/s
    Stream #0:0(und): Video: h264 (High) (avc1 / 0x31637661), yuv420p, 1280x720,
 829 kb/s, 10 fps, 10 tbr, 20 tbn, 20 tbc (default)
      creation_time   : 1970-01-01T00:00:00.000000Z
      handler_name    : VideoHandler
    Stream #0:1(und): Audio: aac (LC) (mp4a / 0x6134706D), 44100 Hz, stereo, flt
p, 191 kb/s (default)
      creation_time   : 2012-11-25T22:19:36.000000Z
      handler_name    : IsoMedia File Produced by Google, 5-11-2011
[libx264 @ 01e7a540] broken ffmpeg default settings detected
[libx264 @ 01e7a540] use an encoding preset (e.g. -vpre medium)
[libx264 @ 01e7a540] preset usage: -vpre <speed> -vpre <profile>
[libx264 @ 01e7a540] speed presets are listed in x264 --help
[libx264 @ 01e7a540] profile is optional; x264 defaults to high
Cannot open video encoder for stream #0
Error occurred: Generic error in an external library

Is it a bug in FFMPEG?? I couldn't get anything to work so far...

More information about the Libav-user mailing list