[Libav-user] Fwd: Re: FFmpeg vp8 decoding: cross compile on Windows for ARM target

Carl Eugen Hoyos ceffmpeg at gmail.com
Thu Aug 2 00:38:02 EEST 2018

2018-07-29 16:20 GMT+02:00, ed mcmurray <emcmurray at aevee.com>:
> I have tried the Window pathname suggestions, with no real success. I've
> decided to eliminate this as a variable, so I have switched to try to
> build FFmpeg libs under Linux(Ubuntu 17.10).  This is the exact process
> that I have followed so far:
> *
> *1: I have downloaded and decompressed ffmpeg v4.0.2 into ffmpeg source
> root directory.
> 2: I have downloaded and installed Pre-buil2 GNU toolchain forArm
> Cortex-M for Linux (gcc-arm-none-eabi-7-2018-q2 update-linux)
>      from Arm website:
> https://developer.arm.com/open-source/gnu-toolchain/gnu-rm
> 3: from cli, I set working directory to ffmpeg source root directory.  (
> I created a simple helloworld.c program in working directory, to test
> compiler)
> 4: from cli,  I verified arm compiler did successfully create expected
> object file for helloworld.c test.
> 5: from cli, I ran cofigure shell script:
> $ ./configure --enable-cross-compile
> --cc=/home/ed/Project/armCrossCompile gcc-arm-none-eabi-eabi-gcc
> --target-os=none arch=arm

(There is something wrong with the "arch" option, both here and in the log.)

Should probably be:
./configure --cross-prefix=/home/ed/Project/armCrossCompile
--target-os=none --arch=arm

> 6: This is the returned error message:
> /home/ed/Project/armCrossCompile/gcc-arm-none-eabi-7-2018-q2-update/bin/arm-none-eabi-gcc
> is unable to create an executable file. C compiler test failed.
> I have attached zipped log file to show any possible clues.  I won't be
> able to do too much more today.  I will start Monday morning trying to
> understand what the log file is showing and what I might be missing.
> Again, any advice is appreciated.

Please do not compress the log, please avoid top-posting here.

If it still fails, try to compile FFmpeg's test program ("int
main(void){ return 0; }")
with the options FFmpeg uses ("-march=armv4t") and find out if it
really succeeds
from cli.

Carl Eugen

More information about the Libav-user mailing list