[FFmpeg-user] relocation R_X86_64_PC32 against symbol `ff_w1111' can not be used when making a shared object; recompile with -fPIC

Gabriel Pettier gabriel.pettier at gmail.com
Tue Aug 25 12:43:50 CEST 2015

I tried with master (from git://source.ffmpeg.org/ffmpeg.git), as well 
as an older commit (1f7b7) that has been tested with ffpyplayer in the 
past, to be sure, since i got the same issue, i went back to master.

I used make clean between each try, and i just tried again with a make 
distclean before to be sure, no dice.

Your command does indeed work for me, i'll try to reduce the CC command 
of my makefile until i find what flag or target is causing issue.

On Tue, Aug 25, 2015 at 09:57:24AM +0000, Carl Eugen Hoyos wrote:
>Gabriel Pettier <gabriel.pettier <at> gmail.com> writes:
>> I tried a lot of different ones, here are a few (by order)
>Did you run "make distclean" after each try?
>What version of FFmpeg is this?
>I was unable to reproduce your issue with the following
>$ ./configure && make libswscale/libswscale.a
>$ gcc libswscale/libswscale.a -shared -o out.so
>Carl Eugen
>ffmpeg-user mailing list
>ffmpeg-user at ffmpeg.org

More information about the ffmpeg-user mailing list