[Libav-user] Unable to compile i386 compatible ffmpeg dylibs on Mac OS X

Carl Eugen Hoyos cehoyos at ag.or.at
Wed Nov 23 01:54:59 CET 2011

Simon Daniels <simondaniels23 at ...> writes:

> I'm running 64-bit Lion but I need to compile a 32-bit version of
> ffmpeg because another library I'm using is only available as 32-bit.
> I've tried a number of different configurations but they're all giving
> me errors. Here's what I've tried:
> ./configure --disable-static --enable-shared --disable-outdev=sdl
> --disable-bzlib --disable-libfreetype --disable-libopenjpeg
> --enable-zlib --enable-runtime-cpudetect --arch=i386
> --extra-cflags="-arch i386" --extra-ldflags="-arch i386"
> --target-os=darwin --enable-cross-compile

What's wrong with "./configure --cc='gcc -m32'"?
Or does this not work on OSX?

If it still fails, please run make again, then run make V=1 and post the
complete, uncut output of make V=1. (Please do not post the complete uncut
output of your first call to make.)

Carl Eugen

More information about the Libav-user mailing list