[Libav-user] UDP Stream Read Pixelation/Macroblock Corruption

radparker radford.parker at gmail.com
Tue Jun 26 15:55:19 CEST 2012

Thanks for the responses! I suppose I should mention that if I try to record
the UDP stream from vlc using 
I have no problems. The output file is completely clean. Also, if I play the
stream through the vlc gui, I have no problems with pixelation (presumably
caused by lost packets). I can play the stream as long as I want with no
problem. Also, when I record the stream with ffmpeg using 
I still don't have any problems. The pixelation only occurs when I use libav
function calls in my own code.

This leads me to believe that it is possible to properly read this stream
using the current libraries I have configured, I'm just not sure what vlc or
ffmpeg are doing differently. 

I have tried recompiling libav after changing UDP_TX_BUF_SIZE to 8 *
tried setting the buffer size using the ?buffer_size parameter. None of
these fixes alters the behavior of the stream reading. I should also mention
that someone else has set up this UDP stream, but it is on a hard-wired
ethernet LAN and the stream is set at ~60 fps. Can anyone else think of a
different approach other than altering the stream to use tcp? Thanks again.

View this message in context: http://libav-users.943685.n4.nabble.com/UDP-Stream-Read-Pixelation-Macroblock-Corruption-tp4655270p4655292.html
Sent from the libav-users mailing list archive at Nabble.com.

More information about the Libav-user mailing list