[Libav-user] av_read_frame returns -32

Bob Self bobslf at gmail.com
Sun Mar 11 10:21:02 CET 2012

On Sun, Mar 11, 2012 at 3:53 AM, Andrey Utkin
<andrey.krieger.utkin at gmail.com> wrote:
> 2012/3/11 Bob Self <bobslf at gmail.com>:
>> The source at that link won't build for me. It uses
>> avcodec_alloc_context3() and  avcodec_open2() that my ffmpeg
>> installation does not have. My avcodec version is 52.72.2 on Ubuntu
>> 11.04. Do you know of a similar example that uses this version?
> Please consider working with recent ffmpeg versions.
> --
> Andrey Utkin
> _______________________________________________
> Libav-user mailing list
> Libav-user at ffmpeg.org
> http://ffmpeg.org/mailman/listinfo/libav-user

I downloaded the current ffmpeg with git clone
git://source.ffmpeg.org/ffmpeg.git ffmpeg
The version of avcodec is 54.10.100

I built it but still get the same error message about
avcodec_alloc_context3() and  avcodec_open2().

Looking this up I read that "THIS FUNCTION IS NOT YET PART OF THE
PUBLIC API! we WILL change its arguments and name a few times!"

What am I missing?

More information about the Libav-user mailing list