[Libav-user] build FFMPEG ubuntu 16

retep peter retepik at gmail.com
Fri Jun 5 18:32:52 EEST 2020

I need a advice :) I have tried compile ffmpeg 2.8.15 from source under
Ubuntu 16 LTS. I need compile it for one SDK, I can't use ffmpeg from
repository. I compiled ffmpeg successfully. But I have got issues with my
specify SDK, when I try compile my code with SDK:

SDK.so: undefined reference to `av_rescale_q at LIBAVUTIL_FFMPEG_54'

I suppose that issues are in symbols name. I tried read symbols with

readelf -s libavutil-ffmpeg.so.54

I get in my compiled ffmpeg something like this

   158: 0000000000024170    55 FUNC    GLOBAL DEFAULT   12

I tried this with libavutil-ffmpeg.so.54 from repository and i get

   158: 0000000000024170    55 FUNC    GLOBAL DEFAULT   12

I suppose that I need add a suffix "FFMPEG" to symbols name. I use this
configuration for build ffmpeg, it same as configuration of build from
repository :

sudo ./configure --prefix=/usr --extra-version=0ubuntu0.16.04.1
--build-suffix=-ffmpeg --toolchain=hardened
--incdir=/usr/include/x86_64-linux-gnu --cc=cc --cxx=g++ --enable-gpl
--enable-shared --disable-stripping --disable-decoder=libopenjpeg
--disable-decoder=libschroedinger --enable-avresample
--enable-avisynth --enable-gnutls --enable-ladspa --enable-libass
--enable-libbluray --enable-libbs2b --enable-libcaca --enable-libcdio
--enable-libflite --enable-libfontconfig --enable-libfreetype
--enable-libfribidi --enable-libgme --enable-libgsm
--enable-libmodplug --enable-libmp3lame --enable-libopenjpeg
--enable-libopus --enable-libpulse --enable-librtmp
--enable-libschroedinger --enable-libshine --enable-libsnappy
--enable-libsoxr --enable-libspeex --enable-libssh --enable-libtheora
--enable-libtwolame --enable-libvorbis --enable-libvpx
--enable-libwavpack --enable-libwebp --enable-libx265 --enable-libxvid
--enable-libzvbi --enable-openal --enable-opengl --enable-x11grab
--enable-libdc1394 --enable-libiec61883 --enable-libzmq
--enable-frei0r --enable-libx264 --enable-libopencv

Could you help me how add suffix "-ffmpeg" to symbols name? Thanks

Best Regard

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://ffmpeg.org/pipermail/libav-user/attachments/20200605/1ec3014d/attachment.html>

More information about the Libav-user mailing list