[FFmpeg-cvslog] ffmpeg: prefer "dec" over "ist->st->codec" in do_video_out() snippet
Stefano Sabatini
git at videolan.org
Tue Apr 19 12:25:30 CEST 2011
ffmpeg | branch: master | Stefano Sabatini <stefano.sabatini-lala at poste.it> | Sun Apr 17 01:38:09 2011 +0200| [6a46aab49b68a79973dfa86f0966c081fc807961] | committer: Stefano Sabatini
ffmpeg: prefer "dec" over "ist->st->codec" in do_video_out() snippet
Simplify, ease readability.
Signed-off-by: Stefano Sabatini <stefano.sabatini-lala at poste.it>
> http://git.videolan.org/gitweb.cgi/ffmpeg.git/?a=commit;h=6a46aab49b68a79973dfa86f0966c081fc807961
---
ffmpeg.c | 4 ++--
1 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/ffmpeg.c b/ffmpeg.c
index f134f88..e86e22f 100644
--- a/ffmpeg.c
+++ b/ffmpeg.c
@@ -1195,8 +1195,8 @@ static void do_video_out(AVFormatContext *s,
av_log(NULL, AV_LOG_INFO,
"Input stream #%d.%d frame changed from size:%dx%d fmt:%s to size:%dx%d fmt:%s\n",
ist->file_index, ist->index,
- ost->resample_width , ost->resample_height , avcodec_get_pix_fmt_name(ost->resample_pix_fmt),
- ist->st->codec->width, ist->st->codec->height, avcodec_get_pix_fmt_name(ist->st->codec->pix_fmt));
+ ost->resample_width, ost->resample_height, avcodec_get_pix_fmt_name(ost->resample_pix_fmt),
+ dec->width , dec->height , avcodec_get_pix_fmt_name(dec->pix_fmt));
if(!ost->video_resample)
ffmpeg_exit(1);
}
More information about the ffmpeg-cvslog
mailing list