[FFmpeg-cvslog] avcodec/xsubdec: replace data_size with got_sub_ptr for better readability
Limin Wang
git at videolan.org
Wed Mar 25 20:13:32 EET 2020
ffmpeg | branch: master | Limin Wang <lance.lmwang at gmail.com> | Tue Mar 24 19:05:16 2020 +0800| [2d244c9a00025acd1745ce9d89f2c681d8e99fd1] | committer: Michael Niedermayer
avcodec/xsubdec: replace data_size with got_sub_ptr for better readability
Signed-off-by: Limin Wang <lance.lmwang at gmail.com>
Signed-off-by: Michael Niedermayer <michael at niedermayer.cc>
> http://git.videolan.org/gitweb.cgi/ffmpeg.git/?a=commit;h=2d244c9a00025acd1745ce9d89f2c681d8e99fd1
---
libavcodec/xsubdec.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/libavcodec/xsubdec.c b/libavcodec/xsubdec.c
index 05c4a64ee5..c1c6e11dc3 100644
--- a/libavcodec/xsubdec.c
+++ b/libavcodec/xsubdec.c
@@ -46,7 +46,7 @@ static int64_t parse_timecode(const uint8_t *buf, int64_t packet_time) {
return ms - packet_time;
}
-static int decode_frame(AVCodecContext *avctx, void *data, int *data_size,
+static int decode_frame(AVCodecContext *avctx, void *data, int *got_sub_ptr,
AVPacket *avpkt) {
const uint8_t *buf = avpkt->data;
int buf_size = avpkt->size;
@@ -169,7 +169,7 @@ FF_ENABLE_DEPRECATION_WARNINGS
bitmap += w;
align_get_bits(&gb);
}
- *data_size = 1;
+ *got_sub_ptr = 1;
return buf_size;
}
More information about the ffmpeg-cvslog
mailing list