[Ffmpeg-devel] [PATCH] updated LGPL AC-3 decoder
Justin Ruggles
justinruggles
Sun Feb 11 19:00:18 CET 2007
Michael Niedermayer wrote:
> [...]
>> uint8_t cmixlev;
>> uint8_t surmixlev;
>> uint8_t dsurmod;
>>
>> uint8_t blksw;
>> uint8_t dithflag;
>> uint8_t cplinu;
>> uint8_t chincpl;
>> uint8_t phsflginu;
>> uint8_t cplbegf;
>> uint8_t cplendf;
>> uint8_t cplcoe;
>> uint32_t cplbndstrc;
>> uint8_t rematstr;
>> uint8_t rematflg;
>> uint8_t cplexpstr;
>> uint8_t lfeexpstr;
>> uint8_t chexpstr[FBW_CHANNELS];
>> uint8_t halfratecod;
>> uint8_t sdcycod;
>> uint8_t fdcycod;
>> uint8_t sgaincod;
>> uint8_t dbpbcod;
>> uint8_t floorcod;
>> uint8_t csnroffst;
>> uint8_t cplfsnroffst;
>> uint8_t cplfgaincod;
>> uint8_t fsnroffst[FBW_CHANNELS];
>> uint8_t fgaincod[FBW_CHANNELS];
>> uint8_t lfefsnroffst;
>> uint8_t lfefgaincod;
>> uint8_t cplfleak;
>> uint8_t cplsleak;
>> uint8_t cpldeltbae;
>> uint8_t deltbae[FBW_CHANNELS];
>> uint8_t cpldeltnseg;
>> uint8_t cpldeltoffst[DBA_SEG_MAX];
>> uint8_t cpldeltlen[DBA_SEG_MAX];
>> uint8_t cpldeltba[DBA_SEG_MAX];
>> uint8_t deltnseg[FBW_CHANNELS];
>> uint8_t deltoffst[FBW_CHANNELS][DBA_SEG_MAX];
>> uint8_t deltlen[FBW_CHANNELS][DBA_SEG_MAX];
>> uint8_t deltba[FBW_CHANNELS][DBA_SEG_MAX];
>>
>> /* Derived Attributes. */
>> int sampling_rate;
>> int bit_rate;
>> int frame_size;
>>
>> int nfchans; // number of channels
>> int lfeon; // lfe channel in use
>>
>> float dynrng; // dynamic range gain
>> float dynrng2; // dynamic range gain for 1+1 mode
>> float chcoeffs[AC3_MAX_CHANNELS]; // normalized channel coefficients
>> float cplco[FBW_CHANNELS][18]; // coupling coordinates
>> int ncplbnd; // number of coupling bands
>> int ncplsubnd; // number of coupling sub bands
>> int cplstrtmant; // coupling start mantissa
>> int cplendmant; // coupling end mantissa
>> int endmant[FBW_CHANNELS]; // channel end mantissas
>
>
> are all these wierd names from the ac3 spec? if no then id strongly vote
> for more readable names cplstrtmant -> coupling_start_mantisse for example
>
> if they are in the ac3 spec then iam undecided if these names should be keept
>
Yes, they are from the AC-3 spec. I actually like them. It makes it
easier for me to understand since I am very familiar with the spec.
Also, the encoder uses many of these same names. I would not be too
opposed to expanding some of the abbreviations for easier reading though.
-Justin
More information about the ffmpeg-devel
mailing list