[FFmpeg-devel] [PATCH] RTP/Vorbis payload implementation (GSoC qual task)
Luca Abeni
lucabe72
Wed Apr 15 12:14:35 CEST 2009
Hi,
I know I am late, but...
On Tue, 2009-04-14 at 15:29 +0100, Colin McQuillan wrote:
[...]
> +
> +static PayloadContext *vorbis_new_extradata(void)
> +{
> + return av_mallocz(sizeof(PayloadContext));
> +}
> +
> +static void vorbis_free_extradata(PayloadContext * data)
> +{
> + av_free(data);
> +}
Why "extradata"? As far as I can see, these functions do not have much
to do with extradata... No?
> +RTPDynamicProtocolHandler ff_vorbis_dynamic_handler = {
> + "vorbis",
> + CODEC_TYPE_AUDIO,
> + CODEC_ID_VORBIS,
> + NULL,
> + vorbis_new_extradata,
> + vorbis_free_extradata,
> + vorbis_handle_packet
> +};
Maybe using named initialisers here would make the code more readable?
Thanks,
Luca
More information about the ffmpeg-devel
mailing list