[FFmpeg-devel] [PATCH] avutil: Move av_rint64_clip_* to internal.h
u at pkh.me
Sun Nov 15 16:35:53 CET 2015
On Sun, Nov 15, 2015 at 10:24:52AM -0500, Ganesh Ajjanagadde wrote:
> >> > IMO rename it to avpriv_rint64_clip() or even ff_rint64_clip() since it's inlined
> >> > and not public/exported.
> >> Just noticed an issue: Ronald mentioned to me that ffserver and other
> >> such programs should not use internal API. This therefore needs to be
> >> exported somehow.
> > If only ffserver needs it, implement it there?
> > Or even better, just delete ffserver.
> I have repeated this many times in the past, but ffserver was given as
> a mere illustration. cmdutils.c also needs it
cmdutils.c has the same problem as any ff tool; it should not use internal
-------------- next part --------------
A non-text attachment was scrubbed...
Size: 473 bytes
Desc: not available
More information about the ffmpeg-devel