[FFmpeg-devel] [PATCH]lavf/mxfdec: Set width to actual coded_width for AVCI50

Carl Eugen Hoyos cehoyos at ag.or.at
Thu Nov 26 00:48:39 CET 2015

On Wednesday 25 November 2015 12:57:07 am Tomas Härdin wrote:
> On Tue, 2015-11-24 at 12:02 +0100, Carl Eugen Hoyos wrote:
> > Hi!
> >
> > Attached patch fixes ticket #5029.
> >
> > Please comment, Carl Eugen
> Looks simple enough, but (ab)using MXFCodecUL like that 
> has a slight stink to it.

It was abused for pix_fmts before, and I added a usage for 
codec_tag in July. MXFCodecUL uses an int for the third 
parameter which is exactly what is needed for width.

> Can we perhaps rename the struct to something that signals 
> its more general use of mapping ULs to integers?

I will rename it if you make a suggestion...

> Another thing: don't we have some table like this for 
> H.264 in MXF already?

There are tables that contain H.263 as codec_id but the 
width is needed for this ticket.

Ok to apply?

Thank you, Carl Eugen

More information about the ffmpeg-devel mailing list