[FFmpeg-devel] RTMP FLV problematic file

Marcin Woźniak marcin at intermania.pl
Wed Apr 3 08:59:49 EEST 2019


I've observed a big problem with one of my sources that i have. It is 
H264 video data and AAC audio (48 khz).

Below is a file that is a dump of part of a stream from this source 
which i try to stream to Youtube LIVE and only what i get is a sound 
with a lot of cracking noise and clear video.

Please note that file is perfectly playable using VLC and ffplay in 
every version that i tried (many of them) also with latest GIT compiled. 
I tried x64 and ARM and same happens.

This is what i tried:

ffmpeg -re -i testAudio.flv  -vcodec copy  -acodec copy -f flv 
-rtmp_live 1 rtmp://x.rtmp.youtube.com/live2/{KEY} = Cracking NOISE

ffmpeg -re -i testAudio.flv  -vcodec libx264 -acodec libmp3lame -f flv 
-strict experimental -rtmp_live 1 rtmp://x.rtmp.youtube.com/live2/{KEY} 

ffmpeg -re -i testAudio.flv  -vcodec copy  -acodec aac -ac 2 -ar 44100 
-f flv -rtmp_live 1 rtmp://x.rtmp.youtube.com/live2/{KEY} = Cracking NOISE

ffplay testAudio.flv = Plays well

This behaviour is not happening on Facebook Live Streaming NOR private 
RTMP server, only YouTube Live.

I've also wrote a test app using lib_srs and this file publishes well on 
YT without cracking sound.

I tried switching Audio Channels Count, Audio Sampling Rate, Codec (AAC,MP3)

This happens only with this file, others works well.

I've checked AAC frames, H264 NAL structure of file - nothing wierd 
inside. To be more pricese i dumped this file from RTSP stream from a 
device using acodec copy and vcodec copy. Same happens when i try to use 
RTSP as a source from this device.

Source file: http://zink.com.pl/testAudio.flv

Any help?

Marcin Wozniak

More information about the ffmpeg-devel mailing list