[FFmpeg-user] Subtitle stream added to QT MOV format even when -snswitch used

Evan Scanlan evan.m.scanlan at gmail.com
Sat Aug 13 20:20:49 CEST 2011

On Sat, Aug 13, 2011 at 1:20 PM, bouke <bouke at editb.nl> wrote:
> ----- Original Message -----
> From: "Evan Scanlan" <evan.m.scanlan at gmail.com>
> To: <ffmpeg-user at ffmpeg.org>
> Sent: Saturday, August 13, 2011 7:00 PM
> Subject: [FFmpeg-user] Subtitle stream added to QT MOV format even
> when -snswitch used
>> Hi,
>> Apologies if this has been posted/solved elsewhere… I searched and did
>> not find this particular issue.  Also, I tried to post this last night
>> and it did not seem to go through -- sorry if this is a double-post.
>> I am using FFMPEG to encode from an Matroska video (mkv) to a
>> Quicktime mov file.  Problem is that mov file includes subtitle stream
>> even when -sn switch is used.  This occurs with both the Fedora 12
>> current packaged binary (ffmpeg-0.7-45_rc1.fc12.x86_64) and with a
>> build from GIT source (about one month old).  It also happens when
>> using the MacPorts FFMPEG.  This does not seem to be a problem when
>> converting from other file formats to mov (e.g. m2ts to mov)
>> Here is a little example using the precompiled binary Fedora package.
>> The second time I run ffmpeg the subtitle stream appears even though
>> conversion was run with -sn the first time.
>> Any help or suggestions would be much appreciated.
> Not sure what and why, but does the metadata (aka text aka subtitle stream)
> bother you?

Thanks for the response!

It mainly bothers me because it makes it so that Quicktime cannot
manipulate the file.  So I cannot save the file from Quicktime nor can
I use other programs like iFlicks (which I think uses Quicktime API)
when the subtitle stream is present.  On other converted mov
containers (without subtitle stream) iFlicks and Quicktime work fine.

> (i mean, does it show on playback?)
> If so, can't you get rid of it in the second pass with mapping? (it appears
> as a seperate stream...)
> (or perhaps map the first pass, or pipe the second pass...)

I tried that... running on the mov file again with -vocdec copy
-acodec copy -sn -f mov ... does not get rid of the subtitle stream.
It stays there and I cannot get rid of it no matter what I have tried.
 Any suggestions on how to trick ffmpeg into removing the stream would
be great!

More information about the ffmpeg-user mailing list