[FFmpeg-user] Pad filter seems to have no effect

David Favor david at davidfavor.com
Tue Aug 23 17:04:59 CEST 2011

David Favor wrote:
> David Favor wrote:
>>>> The command which appears to be correct is:
>>>>    ffmpeg -y -i test.skype.mov -an -vf pad=640:480:640:0:white -map 
>>>> 0.2 -vcodec copy test.video.mov
>>> pad=width:height[:x:y[:color]]
>>> the padded area (specified by width:height) must contain the input
>>> video placed at position 640:0, so it should be:
>>> pad=640+640:480:640:0
>> Already tried your suggestion...
>> This produces no effect:
>>    ffmpeg -y -i test.skype.mov -an -vf pad=1280:480:640:0:white -map 
>> 0.2 -vcodec copy test.video.mov
>> Maybe I best bump up to latest, which is probably 0.7.2 or 0.7.3 and 
>> retest.
> Updated to ffmpeg-0.7.3 and still no effect.
> Neither of these produce any effect:
>      ffmpeg -y -i test.skype.mov -an -vf scale=1280:480 -map 0.2 -vcodec 
> copy test.video.mov
>      ffmpeg -y -i test.skype.mov -an -vf 
> scale=1280:480,pad=1280:480:640:0:white -map 0.2 -vcodec copy 
> test.video.mov
> Maybe the problem is -vcodec copy... although I've tried various
> re-encoding schemes with no effect either.

This works...

     ffmpeg -benchmark -y -i 30sec-test.skype.mov -an -vf pad=1280:480:640:0 -map 0.2 \
            -vcodec libx264 -threads 0 -vpre lossless_fast -crf 25 30sec-test.video.mov

And takes a huge amount of time.

Best estimate on an 8x core machine is around 3 minutes encoding time for every
1 minute of video. Ouch.

Got to be a better way to extract the video streams intact.

I'll start a new thread about the problems with simple mapping to copy the video
streams intact.


Love feeling your best ever, all day, every day?
Click http://RadicalHealth.com for the easy way!

More information about the ffmpeg-user mailing list