[FFmpeg-user] Mpeg4 transcoding problem

P Gabor pgabor1212 at freemail.hu
Tue Jul 12 09:37:58 CEST 2011

I'm using ffmpeg to encode a live mpeg4 stream to a lower resolution mjpeg stream with lower frame rate.
I'm feeding the ffmpeg with depacketized RTP packets via UDP. The RTP packets come frome AXIS network cameras.
In the version 4.9 it worked fine.
But starting with the ffmpeg 5.0 the buffering of the input stream has changed.
I've noticed, that according to the vop_time_increment_resolution field in the mpeg4 stream ffmpeg buffers more or less.
Before the version 5.0 the transcoding started immediately.
But with the version 5.0 ffmpeg started to buffer according to the vop_time_increment_resolution value.
For some cameras this value is 100, for some cameras this value is 1000.
In case of vop_time_increment_resolution=100 ffmpeg starts transcoding after 10-20 seconds,
but in case of vop_time_increment_resolution=1000 it seems like it buffers till the end of times.

For a live streaming system this is unacceptable. My system needs lower latency, than 0.5 seconds.
I've tried to use the -re switch also, but it's useless.

Is it a bug?
Am i using wrong swithes in the command line? (ffmpeg -f m4v -i "udp://127.0.01?localport=30000" -r 10 -s 240x180 -sameq -j mpjpeg -vbsf mjpegadump -)

Thanks for any advice!


More information about the ffmpeg-user mailing list