[FFmpeg-user] "Application provided invalid, non monotonically increasing dts to muxer"; Comcast/Ceton/Windows Media Center/.WTV

Alan Tu 8libra at gmail.com
Sat Jul 16 20:12:02 CEST 2011

Hi, I want to use ffmpeg to convert MPEG-2 streams captured using my
Ceton cable card. However I'm getting the dreaded not monotonically
increasing error. I've done some research and tried various things,
none of which has worked. I'd like to know (1) what is causing this
problem, and/or (2) how to fix it? I'm going to error on the side of
providing more information about my setup as I don't know what is
causing the problem.

I have Comcast digital cable service. The coax connects the cable
outlet in the wall to an Motorola BDA-S2 amplified splitter. The
splitter outputs to a cable modem and the PC. The signal to noise
ratio is 34-37 db, and with the amplifier the signal level is 0-14
dbmv depending on channel. (With a non-amplified standard splitter the
signal level is -15 to -3 dbmv.)

The Windows 7 home premium 64-bit PC has a Ceton InfiniTV card, which
accepts a cable card from Comcast. The cable card is successfully
activated. I can successfully watch live and recorded TV in Windows
Media Center. The channels in question are set to "copy free".

I have a binary build of a recent snapshot of ffmpeg. I want to
convert the WTV files generated by Windows Media Center into smaller
formats for portable and storage applications. But despite trying
various HDTV and standard definition channels, videos of any
significant length crap out with this error. Let's take a typical

Command:ffmpeg -i burn_notice.wtv
ffmpeg version N-31461-g371888c, Copyright (c) 2000-2011 the FFmpeg developers
  built on Jul 14 2011 15:05:53 with gcc 4.6.1
  Duration: 01:01:57.48, start: 1.998251, bitrate: 13518 kb/s
    Stream #0.0[0x16](eng): Audio: ac3, 48000 Hz, 5.1, s16, 384 kb/s
    Stream #0.1[0x17]: Video: mpeg2video (Main), yuv420p, 1920x1080
[PAR 1:1 DAR 16:9], 20000 kb/s, 839.16 fps, 29.97 tbr, 10000k tbn,
59.94 tbc
    Stream #0.2[0x18]: Subtitle: [0][0][0][0] / 0x0000

This is to get an idea of the video file I'm working with.

Command:ffmpeg -i burn_notice.wtv  -an -vcodec copy out.mp4
ffmpeg version N-31461-g371888c, Copyright (c) 2000-2011 the FFmpeg developers
  built on Jul 14 2011 15:05:53 with gcc 4.6.1
[wtv @ 00000000004BD7C0] unsupported chunk:f71002b9ee7ced4ebd7f0540358618a1
[mpeg2video @ 000000000059F100] mpeg_decode_postinit() failure
    Last message repeated 28 times
frame=58442 fps=1700 q=-1.0 size= 3124676kB time=00:32:31.40
[mpeg @ 00000000004E76C0] Application provided invalid, non
monotonically increasing dts to muxer in stream 0: 176284380 >=
av_interleaved_write_frame(): Invalid argument

I'm simply trying to copy the video stream (no transcoding, no audio)
into an MPEG container. I have tried converting from a .DVR-MS file. I
have tried converting to a .mp4 container. I have tried standard
definition files instead of high definition files. I have tried files
from different channels. I have not gotten any files of any useful
lengths to convert.

I have successfully copied out the audio streams, though I have seen
errors doing that too.

Usually the two DTS values that are causing the error are equal. If it
was a transmission error from Comcast (bit flipping), one would think
the DTS values causing ffmpeg to crap out would not be equal almost
every time.

Thoughts? Thanks in advance for taking a look at this issue.


More information about the ffmpeg-user mailing list