[FFmpeg-user] ffmpeg console output

Jonas Kuepper Jonas.Kuepper at cinepostproduction.de
Wed Jul 27 09:32:42 CEST 2011

Hey Mark,

i am not really sure about this, but i think the output you see is the error stream. You may try to route this to a file or /dev/null with
ffmpeg -loglevel 0 -i zion-springdale-ad.flv 2>ffmpeg_logfile.txt
or the like.

This output can also be blamed for not executing ffmpeg in the background because the process has no output stream to write this messages to.

But again, i didn't try this and I'm not sure.


Von: ffmpeg-user-bounces at ffmpeg.org [ffmpeg-user-bounces at ffmpeg.org]" im Auftrag von "Mark G. Lind [mglind at utah.com]
Gesendet: Dienstag, 19. Juli 2011 18:50
An: ffmpeg-user at ffmpeg.org
Betreff: [FFmpeg-user] ffmpeg console output

Is there a way to suppress the console output from ffmpeg run from the
command line.

I tried using -loglevel quiet and -loglevel 0, but still get console output.

Console output looks like this:

6418050617# ffmpeg -loglevel 0 -i zion-springdale-ad.flv

FFmpeg version 0.6.1, Copyright (c) 2000-2010 the FFmpeg developers

  built on Mar 18 2011 13:44:13 with gcc 4.2.1 20070719  [FreeBSD]

  configuration: --prefix=/usr/local --mandir=/usr/local/man --enable-shared
--enable-gpl --enable-postproc --enable-avfilter --enable-avfilter-lavf
--enable-pthreads --enable-x11grab --enable-memalign-hack --cc=cc
--extra-cflags=-msse -I/usr/local/include/vorbis -I/usr/local/include
--extra-ldflags=-L/usr/local/lib --extra-libs=-pthread --disable-debug
--disable-indev=alsa --disable-outdev=alsa --enable-libopencore-amrnb
--enable-version3 --enable-libopencore-amrwb --enable-version3
--disable-libdirac --enable-libfaac --enable-nonfree --enable-libfaad
--enable-libfaadbin --disable-libgsm --enable-libmp3lame
--enable-libopenjpeg --enable-libschroedinger --disable-ffplay
--disable-libspeex --enable-libtheora --enable-libvorbis --enable-libvpx
--enable-libx264 --disable-libxvid

  libavutil     50.15. 1 / 50.15. 1

  libavcodec    52.72. 2 / 52.72. 2

  libavformat   52.64. 2 / 52.64. 2

  libavdevice   52. 2. 0 / 52. 2. 0

  libavfilter    1.19. 0 /  1.19. 0

  libswscale     0.11. 0 /  0.11. 0

  libpostproc   51. 2. 0 / 51. 2. 0

Seems stream 0 codec frame rate differs from container frame rate: 1000.00
(1000/1) -> 29.92 (359/12)

At least one output file must be specified

Whenever ffmpeg is called this is the minimal output and it fills up much
web server logs.

Also, when I try to run an ffmpeg command in a shell script and try to put
it in the background it doesn't run. When it gets put in the background the
job is just suspended and output a line like this.

[1]          + Suspended (tty output)            ./ffmpeg-mbr somefile.flv

ffmpeg-mbr just runs multiple ffmpeg commands to output files at multiple
bit rates.

I have two problems I need to resolve.

1. ffmpeg filling up web server logs

2. ffmpeg not running in the background on a linux server

Thanks for your help.


ffmpeg-user mailing list
ffmpeg-user at ffmpeg.org

More information about the ffmpeg-user mailing list