[FFmpeg-user] ffmpeg installed properly? Noob

Tom Step t.step at comcast.net
Wed Sep 14 23:03:41 CEST 2011

installed LAME, x264, and faac/faad libs, then tried to install ffmpeg again with all libs, then without, still get yasm error (isn't that a linux thing?)

shoeis-computer:~ shoei$ cd ~/ffmpeg/ffmpeg-HEAD-d2a847c/
shoeis-computer:ffmpeg-HEAD-d2a847c shoei$ ./configure
yasm not found, use --disable-yasm for a crippled build

If you think configure made a mistake, make sure you are using the latest
version from Git.  If the latest version fails, report the problem to the
ffmpeg-user at ffmpeg.org mailing list or IRC #ffmpeg on irc.freenode.net.
Include the log file "config.log" produced by configure as this will help
solving the problem.

On Sep 14, 2011, at 11:45 AM, Tom Step wrote:

> Downloaded Git version to Downloads folder. it created a folder called "ffmpeg-HEAD-d2a847c" which has another "ffmpeg-HEAD-d2a847c" folder within it, which has the configure executable.
> Now in Terminal do I:
> cd ~/Downloads/ffmpeg-HEAD-d2a847c/ffmpeg-HEAD-d2a847c
> ./configure --enable-libmp3lame --enable-shared
> make
> sudo make install
> Wil this make a "clean" install with necessary parts?
> and
> What about other errors with different codecs? FWIW I did run the original configure with--libmp3lame in it.And I do have libfaac but can't make a .aac versions either...
> Thanks for helping a noob out
> Tom
> On Sep 13, 2011, at 5:50 PM, Lou wrote:
>> On Tue, 13 Sep 2011 15:21:29 -0600
>> Tom Step <t.step at comcast.net> wrote:
>>> Tyring to install ffmpeg on my Mac (OS 10.6.8) to learn CLI. Used
>>> MacPorts to do install, it came back with a ton of errors, then did
>>> port clean ffmpeg, then:
>>> svn checkout svn://svn.ffmpeg.org/ffmpeg/trunk ffmpeg
>>> Checked out revision 26402.
>> FFmpeg uses Git now. The SVN repository is outdated. You should switch
>> to the Git repository as the last SVN commit was in January 2011 (or
>> simply download a Git snapshot):
>> http://git.videolan.org/?p=ffmpeg.git;a=snapshot;h=HEAD;sf=tgz
>>> ./configure --enable-shared --disable-mmx --arch=x86_64
>> --disable-mmx was used for PowerPC I think. I don't think you need it
>> for the recent architecture. But IANAMacUser.
>> More importantly, if you want mp3 encoding support, you need to install
>> lame and build ffmpeg with --enable-libmp3lame.
>>> shoeis-computer:Volumes shoei$ ffmpeg -i ~/Desktop/Hunger.m4a mp3 -ab
>>> 192k ~/Desktop/Hunger.mp3
>> Your command is telling ffmpeg that your output is a file named "mp3".
>> Once you recompile ffmpeg with --enable-libmp3lame the remove the
>> superfluous "mp3" from your command and it might work, and if not then
>> add "-acodec libmp3lame".
>> _______________________________________________
>> ffmpeg-user mailing list
>> ffmpeg-user at ffmpeg.org
>> http://ffmpeg.org/mailman/listinfo/ffmpeg-user
> _______________________________________________
> ffmpeg-user mailing list
> ffmpeg-user at ffmpeg.org
> http://ffmpeg.org/mailman/listinfo/ffmpeg-user

More information about the ffmpeg-user mailing list