[FFmpeg-user] live stream transcoding problem

Robert Harakaly r.harakaly at gmail.com
Tue Mar 13 13:36:34 CET 2012

Carl, Andrey,

I'm not sure if my last mail from Saturday passed. 

In fact it seems the bug still (partially) persist. I took the latest
snapshot from you web site and I tried. There is critical period (first
60-90 frames) where it still fails as I described in my first mail. It
looks like using multiple threads (option threads=2 or 4) makes this
behaviour worse.
When it passes this period it fails later but there the error messages

The fifo_size seems helps but after I get a huge amount of error mpeg2

Any idea?


On Fri, 2012-03-09 at 16:05 +0200, Andrey Utkin wrote:
> 2012/3/9 Carl Eugen Hoyos <cehoyos at ag.or.at>:
> > Robert Harakaly <r.harakaly <at> gmail.com> writes:
> >
> >> ffmpeg version 0.9, Copyright (c) 2000-2011 the FFmpeg developers
> >
> > Please test current git head, it always contains less bugs and
> > more features than any released version.
> > (And there have been changes in the network code iirc.)
> >
> > Carl Eugen
> +1.
> If still doesn't work - then this known bug is not fixed yet. Try
> appending this to your udp input URL:
> ?fifo_size=0
> If you get bad quality video after this, increase wmem_max sysctl
> variable, and append sth like '&buffer_size=10000000' to input URL.

More information about the ffmpeg-user mailing list