[FFmpeg-user] ffmpeg only works for one user.

Reindl Harald h.reindl at thelounge.net
Thu Aug 15 09:42:59 CEST 2013

Am 15.08.2013 06:33, schrieb Leonard Bogard:
> On Wed, Aug 14, 2013 at 8:13 PM, Reindl Harald <h.reindl at thelounge.net>wrote:
>> Am 15.08.2013 05:05, schrieb Leonard Bogard:
>>>>> ~$ whereis ffmpeg
>>>>> ffmpeg: /usr/local/bin/ffmpeg
>>>> No, it isn't the ffmpeg you installed follow the instruction at
>>>> http://ffmpeg.org/trac/ffmpeg/wiki/UbuntuCompilationGuide . I have a
>>>> glance at this instruction, the correct ffmpeg here should
>>>> be: /home/INSTALL_USER/bin/ffmpeg .
>>>> So, try "/home/INSTALL_USER/bin/ffmpeg" when login with
>>>> another user.
>>> Simple solution. GAH!  Thanks, it worked
>> now ask yourself two things careful:
>> * why in the world has one user permission to the userhome of another one
>>   on your machine
> To be honest, I have no idea, and at this point I really don't care since
> there isn't going to be a large userspace anyways.  Infact, only www-data
> (the account the webserver is running from) needs access

*wow* this should become a production webserver and you have no idea
why everybody and his brother can access userhomes?

why do you not hire someone with a clue?

>> * why do you use instructions installing in your userhome if you
>> want to share the binary with other users?
> Because it was the only one I could get working the way I needed it. Had
> their been a complete install instructions that worked, I would have used

what about asking for help with specific querstions and problem
descriptions if you are about?

this way below you get ffmpeg with a *static linked* recent x264
well you need to switch the path because obviously the fool built
you installed package is still using /usr/local/ and enable some
things i do not need

but the point is i can install the this way built package parallel
to the Fedora ones (even both as RPM because i never ever would build
as root or install without making a distribution package) and i replaced
the rpm-macros with direct commands and paths for you........

./configure \
 --host=x86_64-redhat-linux \
 --prefix=/usr/local \
 --exec-prefix=/usr/local \
 --bindir=/usr/local/bin \
 --libdir=/usr/local/lib64 \
 --includedir=/usr/local/include \
 --extra-ldflags="-Wl,-z,now -Wl,-z,relro,-z,noexecstack" \
 --enable-static \
 --disable-shared \
 --disable-avs \
 --disable-cli \
 --disable-ffms \
 --disable-gpac \
 --disable-lavf \
 --disable-opencl \
make install

../configure \
 --prefix=/usr/local \
 --bindir=/usr/local/bin \
 --datadir=/usr/local/share/ffmpeg \
 --incdir=/usr/local/include/ffmpeg \
 --libdir=/usr/local/lib64 \
 --mandir=/usr/local/man \
 --arch=x86_64 \
 --extra-cflags="-I/usr/local/x264" \
 --extra-ldflags="-I/usr/local/x264 -L/usr/local/x264 -ldl -Wl,-z,now -Wl,-z,relro,-z,noexecstack" \
 --enable-nonfree \
 --enable-gpl \
 --enable-version3 \
 --enable-libmp3lame \
 --enable-libtheora \
 --enable-libx264 \
 --enable-libvpx \
 --disable-libopus \
 --enable-static \
 --enable-libvorbis \
 --enable-libfaac \
 --enable-runtime-cpudetect \
 --disable-librtmp \
 --disable-shared \
 --disable-libxvid \
 --disable-libspeex \
 --disable-libopencore-amrnb \
 --disable-libopencore-amrwb \
 --disable-libopenjpeg \
 --disable-libopencv \
 --disable-libschroedinger \
 --disable-libgsm \
 --disable-libfreetype \
 --disable-hwaccels \
 --disable-libdc1394 \
 --disable-devices \
 --disable-amd3dnow \
 --disable-protocol=gopher \
 --disable-ffplay \
 --disable-ffprobe \
 --disable-avdevice \
 --disable-debug \
 --disable-htmlpages \
 --disable-podpages \
make install

> Point of note: the third party PPA that someone suggested didn't work either

noboddy can help with "didn't help either"
*what exactly was the commandline and the uncutted output*

> I forget what all I had to change and strip out of my original
> ffmpeg startup script but in the end it just would not work.

what is a ffmpe startup script?

> I am still very amenable to and can still try to install a proper globally
> accessible compiled ffmpeg (with libfdk-aac, libfaac, libx264, libmp3lame,
> libopus, libvpx.)  

i do not believe you need libfdk-aac *and* libfaac
they are doing *the same*

> However, I need to go live with this new machine Sunday
> and it needs to be working from the web page for easy and fast access.

do yourself and the internet a favor and do *not* connect servers
in such a braindead timeline to the internet while you have no
clue how your operating system works - why does everybody and his
brother think he needs to play admin?

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 263 bytes
Desc: OpenPGP digital signature
URL: <http://ffmpeg.org/pipermail/ffmpeg-user/attachments/20130815/3e118fc0/attachment.asc>

More information about the ffmpeg-user mailing list