[FFmpeg-user] libutvideo causes Segmentation fault

Johann Rekowski johann.rekowski at googlemail.com
Sun Mar 10 18:17:12 CET 2013

On 3/10/2013 4:52 PM, Peter B. wrote:
> On 03/10/2013 03:17 PM, Johann Rekowski wrote:
>> Hello dear ffmpeg developers,
>> I'm having trouble with recording a video using the utvideo codec. It
>> instantly causes a Segmentation fault (core dumped) once I start encoding.
>> I'm using the latest Arch Linux with the latest kernel from official
>> repositories (3.7.10-1-ARCH). I'm trying to do a screencast with the
>> utvideo codec.
> In case you're using the ut-video codec to capture lossless, is there
> any reason for not using FFv1 for that purpose?
> Regards,
> Pb
> _______________________________________________
> ffmpeg-user mailing list
> ffmpeg-user at ffmpeg.org
> http://ffmpeg.org/mailman/listinfo/ffmpeg-user
I thought that FFv1 is deprecated and not able to use multithreading. I 
wanted to record a game play with utvideo without extremely exhausting 
CPU Core #0 and still being able to play my game smoothly. I did this 
already on Windows with Dxtory, but on Linux this is completely 
different. Please understand that I am no expert in ffmpeg and utvideo 
development, I have just recently started out with Arch Linux to learn 
more about GNU/Linux overall, and then slowly switch to it, leaving 
Windows one day.

On 3/10/2013 4:28 PM, Carl Eugen Hoyos wrote:
> Johann Rekowski <johann.rekowski <at> googlemail.com> writes:
>> Segmentation fault (core dumped)
> Could you provide a backtrace?
> If not, did you test the native encoder?
> Any reason not to use it?
> Thank you, Carl Eugen
> _______________________________________________
> ffmpeg-user mailing list
> ffmpeg-user at ffmpeg.org
> http://ffmpeg.org/mailman/listinfo/ffmpeg-user
I have tried several command line options (e. g. utvideo, libutvideo) 
but it only returns a "command not found" message. I might have to 
compile it static to be able to use the native encoder, but currently I 
am clueless. (I am still trying stuff around, there is no good 
documentation about how to compile and how to use utvideo codec, I did 
this all on my own until the compiling phase worked.)

How do I backtrace something?

More information about the ffmpeg-user mailing list