[FFmpeg-user] "error, non monotone timestamps"

Zarathustra leelacade at centurylink.net
Tue May 28 00:43:32 CEST 2013

And a big thank-you to me...  Ran into the problem again today and didn't
remember the answer was to not code "-acodec  copy", but "-acodec
libmp3lame" or whatever you like.  Fixed it again.  Meanwhile, no movement

This is sooooo typical.  You have a bug report for this when one is encoding
a mkv, and every thread it's mentioned says stuff like, "have you opened a
report for mp4", etc.  This is real simple. 

The error message is wrong.  If you're going to throw everything up in the
air and quit, then explain why. As it stands the error handler closes the
file and the caller says, "Oh, can't write to file" and exits.  THAT is
something that is not a solution.  Oh, might want to sit down.  This will be
a huge shock.  *whispers*  (You could ignore the error and continue coding
with the sync params from before the error and it would work just fine!  But
you'd rather have the program fail so that you KNOW there was a glitch of no
consequence in the source.  Wouldn't you?  Hey, the programmer know more
about what you want to do than you do!)

-async 1 is a special case where only the start of the audio stream is
corrected without any later correction.  It is often helpful when you have
audio and video out of sync, but the streams are the correct (same) length,
and you just want it to start together and then keeping writing at that rate
without trying to "help you".  Yeah, it's one of the few examples where you
can turn off the wonderful feature that doesn't work.

This is how MS works.  Why improve your product when you can dominate the
market and define professionalism so that no one tries to do any better?  I
worked on that crap from version 0.1 in 1981 until the late '80s and what
I'm seeing in the Linux community now feels like we're going exactly the
same way.  Yeah, I know that's out of left field, but...never mind.   You'll
never get it.  Yeah, it's different.  Ever noticed Calculator, Notepad and
Paintbrush aren't like the rest of Windoze?  Strong central metaphor about
how to use it leveraging everyday experience, ability to think about your
work, not the tool, didactic GUI...  That was me.  People who don't really
get what I'm talking about have accepted the Microshaft philosophy.

And a thread is relevant until the bug is fixed.  Groids.  (For the
linguistically challenged that think anything not in Urban Dictionary is a
neologism, it's a nerd without the socially acceptable spin)

View this message in context: http://ffmpeg-users.933282.n4.nabble.com/error-non-monotone-timestamps-tp2016807p4659354.html
Sent from the FFmpeg-users mailing list archive at Nabble.com.

More information about the ffmpeg-user mailing list