[FFmpeg-user] configure error - libmp3lame

David Favor david at davidfavor.com
Mon Nov 4 13:05:34 CET 2013

Michael Fletcher wrote:
> Hello,
> I am trying to configure and install FFmpeg on CentOS 5.  I am working through the dependencies, but having a problem with libmp3lame.
> This is my configure command:
> ./configure --extra-cflags=-I/home/mike/ffmpeg_build/include --extra-ldflags=-L/root/ffmpeg_build/lib --extra-libs=-ldl --as=yasm --disable-shared --disable-ffplay --enable-static --enable-filters --enable-fontconfig --enable-gpl --enable-nonfree --enable-postproc --enable-pthreads --enable-runtime-cpudetect --enable-libfreetype --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopus --enable-libtheora --enable-version3 --enable-libvorbis --enable-libx264 --enable-libxavs --enable-libxvid --enable-zlib
> This is the response I get:
> ERROR: libmp3lame >= 3.98.3 not found
> I have installed libmp3lame 3.99 64bit version.  I have also installed the i386 version just to be sure.  Here is find after running the RPM install for libmp3lame.
> find / -name libmp3lame*
> /usr/lib64/libmp3lame.so.0.0.0
> /usr/lib64/libmp3lame.so.0
> /usr/lib/libmp3lame.so.0.0.0
> /usr/lib/libmp3lame.so.0
> Here is the RPM listing showing both installed:
> rpm -qa | grep -i libmp3lame
> libmp3lame0-3.99.3-23.el5
> libmp3lame0-3.99.3-23.el5
> Your help is greatly appreciated.
> Mike Fletcher

The configure file shows lame version + support is determined via:

     enabled libmp3lame && require "libmp3lame >= 3.98.3" lame/lame.h lame_set_VBR_quality -lmp3lame

So first test is lame/lame.h which usually becomes available
when you install your Distro's version of the lame-dev package.

In Ubuntu + Debian this package is...


You can check your system for this file via the command:

     locate lame/lame.h

Which should show something like...


Love Living Well Doing What You Love?
http://DavidFavor.com/books can help!

More information about the ffmpeg-user mailing list