[FFmpeg-user] Help transcoding TS files

Young Kim shadowing71 at gmail.com
Wed Nov 27 08:06:49 CET 2013

Hey all,

I've been trying to transcode some TS files with the requirement that the
PTS is preserved in both the audio and video. However, I've been having
some issues with this. In particular, here's an example of a command I've

ffmpeg -re -i raw/4bZe7TBKQ8Q1p3B_1384459221193_1384459221193_094.ts -s
640x480 -vcodec libx264 -vprofile main -preset veryfast -tune animation
-acodec copy -y -mpegts_copyts 1

After running this, I ran ffprobe to make sure that the duration and pts of
both is similar, but it's a bit off:


duration - 9.968
stream_info - {'audio': {'duration_ts': 898610, 'start_pts': 83149425},
'video': {'duration_ts': 897120, 'start_pts': 83150550}}


duration - 9.968289
stream_info - {'audio': {'duration_ts': 898610, 'start_pts': 7508},
'video': {'duration_ts': 897146, 'start_pts': 7508}}

I've tried using vsync, async, copyts, and copytb to see if it would fix
the problem, but a combination of these either freezes ffmpeg or results in
the same results as above. Does anyone have any suggestions?


More information about the ffmpeg-user mailing list