[FFmpeg-user] Errors Compiling FFMPEG on MIPS

Carl Eugen Hoyos cehoyos at ag.or.at
Wed Aug 27 14:11:54 CEST 2014

C E Macfarlane <c.e.macfarlane <at> macfh.co.uk> writes:

> I've tried:
> 	ffmpeg-2.2.tar.gz, downloaded 28-03-2014
> 	ffmpeg-2.2.7.tar.gz, downloaded within the last couple of days
> 	ffmpeg-2.3.3.tar.gz, downloaded within the last couple of days

Why didn't you try current git head which is the 
only version supported on this mailing list?
(It won't make a difference but since a fix will 
only reach current git head, you will have to 
test in any case.)

> Various configuration options have been tried, 
> based around:


> ./configure --prefix=/opt/share --enable-gpl 

> --enable-nonfree

Please remove it, it has no effect except changing 
the license of your binaries (you may not pass 
them on.)

> --enable-shared

This is ok, but it may make sense to test without 
it first.

> --arch=mips

This is definitely wrong:
Either you are cross-compiling, then this is 
needed but many options are missing, or you 
are not cross-compiling, then --arch should 
not be used.

> --disable-mips32r2 --disable-mipsdspr1 
> --disable-mipsdspr2 --disable-mipsfpu

Are they really all necessary?
I ask because some effort was put into 
optimisations for arm and you disable 
them all afaict...

> CC      libavdevice/alldevices.o
> In file included from ./libavutil/internal.h:167,
>                  from ./libavutil/common.h:415,
>                  from ./libavutil/avutil.h:289,
>                  from ./libavutil/log.h:25,
>                  from libavdevice/avdevice.h:46,
>                  from libavdevice/alldevices.c:22:
> ./libavutil/libm.h:88: error: static declaration of 
> 'fminf' follows non-static declaration

Please provide the following:
Output of: $ grep HAVE_FMINF config.h
The content of config.log starting with 
"check_mathfunc fminf" until "check_mathfunc"
And the output of "make V=1 libavdevice/alldevices.o"

Carl Eugen

More information about the ffmpeg-user mailing list