[FFmpeg-user] ERROR: libass not found using pkg-config

Linov Suresh linov.suresh at gmail.com
Sun Dec 28 22:12:31 CET 2014

Hi there,

I tried to install VLC player from the source. I tried to install the
dependencies like ffmpeg, and I got error,

[root at test01 ffmpeg-2.5.2]# sed -i 's/-lflite"/-lflite -lasound"/'
configure && ./configure --prefix=/usr --enable-gpl --enable-version3
--enable-nonfree --disable-static --enable-shared --disable-debug
--enable-libass --enable-libfdk-aac --enable-libmp3lame
--enable-libtheora --enable-libvorbis --enable-libvpx --enable-libx264
--enable-x11grab --docdir=/usr/share/doc/ffmpeg-2.5.2 && make && gcc
tools/qt-faststart.c -o tools/qt-faststart
ERROR: libass not found using pkg-config

If you think configure made a mistake, make sure you are using the latest
version from Git.  If the latest version fails, report the problem to the
ffmpeg-user at ffmpeg.org mailing list or IRC #ffmpeg on irc.freenode.net.
Include the log file "config.log" produced by configure as this will help
solve the problem.

I have aleady installed Libass, and it's dependencies FreeType and FriBidi

1. FreeType
2. FriBidi

1. FreeType

# sed -i  -e "/AUX.*.gxvalid/s@^# @@" -e "/AUX.*.otvalid/s@^# @@"
modules.cfg && sed -ri -e 's:.*(#.*SUBPIXEL.*) .*:\1:'
include/config/ftoption.h  && ./configure --prefix=/usr --disable-static &&

make install && install -v -m755 -d /usr/share/doc/freetype-2.5.4 && cp -v
-R docs/* /usr/share/doc/freetype-2.5.4

Ref: http://www.linuxfromscratch.org/blfs/view/svn/general/freetype2.html

2. FriBidi

sed -i "s|glib/gstrfuncs\.h|glib.h|" charset/fribidi-char-sets.c && sed -i
"s|glib/gmem\.h|glib.h|" lib/mem.h && ./configure --prefix=/usr && make
make check
make install

Ref: http://www.linuxfromscratch.org/blfs/view/svn/general/fribidi.html

*Install Libass*

export PKG_CONFIG_PATH=/usr/lib/pkgconfig
export PKG_CONFIG=/usr/bin/pkg-config

./configure --prefix=/usr --disable-static && make

make install

Ref: http://www.linuxfromscratch.org/blfs/view/svn/multimedia/libass.html

Also including the config.log herewith.

Great if you can help me on this,


   Linov Suresh
-------------- next part --------------
A non-text attachment was scrubbed...
Name: config.log
Type: text/x-log
Size: 229530 bytes
Desc: not available
URL: <https://ffmpeg.org/pipermail/ffmpeg-user/attachments/20141228/e1465a2a/attachment.bin>

More information about the ffmpeg-user mailing list