[FFmpeg-user] Building ffmpeg with mingw/msys

Jeremy Greene jeremy at ZeeVee.Com
Mon May 5 00:33:05 CEST 2014


I was able to build ffmpeg with mingw/minsys a year or so ago, but with my new laptop, have had no success after hours of trying.

First, I did the mingw(32)/msys. That basically worked except that I couldn’t build lib264 due to a bug (no working C compiler) that people seemed to think was solved by using mingw-w64. So I’ve been trying to do that, but wow… what a random set of results.

First, there seems to be so many ways to get it… but in following the steps from the ffmpeg web site
Leaves me totally baffled since the concept of “mingw/msys” seems to only exist on that page. If I follow the link that is shown to supposedly get “mingw/msys”, it goes to
Which only install mingw-w64. No msys in sight.

So, then I found this other page… which says to get msys I download the following:
So, I download msys, and then as the web page says, I check to see if msys/bin/bash exists… and it does not.
Whether that is the cause for the  very next step on the web page (/msys/msys.bat) to fail is anyone’s guess.

Anyway… has anyone really done this recently and if so, could they, with huge appreciation on my part, help me?!?


More information about the ffmpeg-user mailing list