[FFmpeg-user] Missing packages for building ffmpeg 2.1 with Homebrew for Mac in Mavericks 10.9.2

L. Lee llee040 at sbcglobal.net
Wed May 14 22:26:34 CEST 2014

On 4/10/14, 3:14 PM, "L. Lee" <llee040 at sbcglobal.net> wrote:

>Using Homebrew, today I finally compiled and installed ffmpeg 2.1 for the
>first time since upgrading my Mac to Mavericks. The Homebrew formula for
>ffmpeg 2.1 that I used came from
>https://gist.github.com/victusfate/5969117.   I found that many
>dependencies needed to be removed then reinstalled. Here is the entire
>command and options that finally allowed success:
>brew install ffmpeg2 --with-fdk-aac --disable-ffserver --enable-gpl
>--enable-libass --enable-libfaac --enable-libfdk-aac --enable-libmp3lame
>--enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libspeex
>--enable-librtmp --enable-libtheora --enable-libvpx --enable-pthreads
>--enable-x11grab --enable-libx264 --enable-nonfree --enable-version3
>--with-ffplay --with-frei0r --with-libvpx  --with-openjpeg --with-opus
>--with-rtmpdump --with-schroedinger --with-speex --enable-libfaad
>Included below is a list of 3 options that I had previously used that
>today caused compiling to fail, and the errors reported for each. I tried
>everything I could think of, but still couldn't make any of the 3 work.
>Uninstalling and reinstalling libvorbis didn't help, the same was true in
>the case of freetype , and I don't know what Homebrew package might
>affect "libvo-aacenc". Can anybody tell me what packages I can try
>installing or reinstalling or anything else I can do to satisfy the
>dependencies specified? Thanks.
>-with-freetype ERROR: freetype2 not found
>-with-libvo-aacenc ERROR: libvo_aacenc not found
>-with-libvorbis ERROR: libvorbis not found
>Laine Lee

Because I haven¹t received a reply after a month, I¹m providing a progress

With a fresh installation of Homebrew on a 10.9.2 Mavericks system, I was
able to install ffmpeg2 using the default configuration of the 3rd party
Homebrew formula by first performing Homebrew installations of lame and

On the existing system I continued to have problems with errors for
freetype, libvo-aacenc, and libvorbis even after applying more recent
updates for Homebrew. The remedy required several steps. I used ³brew
doctor² to help identify and remove some out of place libraries related to
lame, libogg, libvorbis, and libvo-aacenc. It was also necessary to use
³brew uninstall² to remove those 4 packages, then ³brew install² to
reinstall them. Afterwards, the only remaining error was ³freetype2 not
found². That problem seemed to be solved by using the ³‹HEAD²
configuration option.	

Laine Lee

More information about the ffmpeg-user mailing list