[FFmpeg-user] MP3 enconding bitrate

Paulo Fidalgo paulo.fidalgo.pt at gmail.com
Sun Oct 26 20:29:25 CET 2014

After making another test with lame and ffmpeg and using the same input 
file, every file from lame works although none of ffmpeg files have worked.

lame -b 256 2L38_01_96kHz.wav 2L38_01_96kHz-lame-256.mp3
lame -V 0 2L38_01_96kHz.wav 2L38_01_96kHz-lame-V0.mp3
lame -V 1 2L38_01_96kHz.wav 2L38_01_96kHz-lame-V1.mp3
ffmpeg -i 2L38_01_96kHz.wav -codec:a libmp3lame -qscale:a 0 
ffmpeg -i 2L38_01_96kHz.wav -codec:a libmp3lame -qscale:a 1 
ffmpeg -i 2L38_01_96kHz.wav -codec:a libmp3lame -qscale:a 2 
ffmpeg -i 2L38_01_96kHz.wav -codec:a libmp3lame -qscale:a 3 
ffmpeg -i 2L38_01_96kHz.wav -codec:a libmp3lame -qscale:a 4 

Now I don't have any clue of what is going on... and what is causing 
this malfunction.

Also I've found that Amarok, the package which leads me to this 
behaviour is also using 4 as audio quality value.

On 25/10/14 13:09, Carl Eugen Hoyos wrote:
> Paulo Fidalgo <paulo.fidalgo.pt <at> gmail.com> writes:
>> I have trouble to get the mp3 encoded right to play
>> on my Volvo Infotainment System (Sensus 3.0), so I
>> have contacted the costumer support, and they told
>> me that the files are being encoding with frames
>> with more than 320Kbps of bitrate.
> Please ask them to explain which frame has >320kb, I
> don't think it's true, see below.
>> Since I don't have a tool to debug it, I've tried to
>> see in codec statistics in VLC, which for the files
>> I'm showing as example I've seen 380Kbps near 3:31
>> mins.
> I played the encoded file you uploaded with vlc,
> it does not show a bitrate of >320 here at any
> time.
> I then analyzed the file you uploaded:
> $ ffmpeg -i outff.mp3 -acodec copy -f image2 -map 0 out%5d
> The largest mp3 frame in your encoded file is 960 bytes
> which corresponds to 320kb/s.
> Maybe you should test the following to verify:
> $ lame -b 320 input.wav out320.mp3
> $ lame -b 256 input.wav out256.mp3
> Do both files play in your car?
> Or only the second?
>> I believe it's a bug on ffmpeg, although I'm not sure,
>> so I'm asking for advice here, since encoding with the
>> lame it works like a charm.
> lame documentation states that the default for lame's
> -q option is 5 but if you use -V, the default is lower
> (4 or smaller for your input sample).
> This may be a bug, either in the documentation of
> FFmpeg (because it states that FFmpeg's option -q
> corresponds to -V which is mostly does but not exactly)
> or because FFmpeg sets lame's -q to 5 if you don't
> specify anything else.
>> I've encoded with this command:
>> ffmpeg -i 2L38_01_96kHz.flac -codec:a libmp3lame
>> -qscale:a 0 2L38_01_96kHz.mp3
> Please test with -compression_level 4, this should
> produce output files more similar with lame.
> Carl Eugen
> _______________________________________________
> ffmpeg-user mailing list
> ffmpeg-user at ffmpeg.org
> http://ffmpeg.org/mailman/listinfo/ffmpeg-user

More information about the ffmpeg-user mailing list