[FFmpeg-user] Răspuns: Răspuns: Cannot install ffmpeg Solaris

Dustinta Cristian dst_cristi_16 at yahoo.ro
Thu Feb 5 15:41:31 CET 2015

>bash-3.2# uname -aSunOS su240tm08 5.10 Generic_147147-26 sun4u sparc SUNW,Sun-Fire-V240

I ran "./configure && gmake libavformat/udp.o" ( I used gmake instead of make because I'm using Solaris) and then I ran twice "gmake V=1 libavformat/udp.o". Here is the output of the second run:

>bash-3.2# gmake V=1 libavformat/udp.ogcc -I. -I./ -D_ISOC99_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_POSIX_C_SOURCE=200112 -D_XOPEN_SOURCE=600 -DZLIB_CONST -DHAVE_AV_CONFIG_H -std=c99 -fomit-frame-pointer -pthread -g -Wdeclaration-after-statement -Wall -Wdisabled-optimization -Wpointer-arith -Wredundant-decls -Wwrite-strings -Wundef -Wmissing-prototypes -Wstrict-prototypes -Wno-parentheses -Wno-switch -Wno-format-zero-length -O3 -fno-math-errno -Wformat  -MMD -MF libavformat/udp.d -MT libavformat/udp.o -c -o libavformat/udp.o libavformat/udp.cgcc: unrecognized option `-pthread'libavformat/udp.c: In function `udp_join_multicast_group':libavformat/udp.c:174: error: storage size of 'mreq' isn't knownlibavformat/udp.c:174: warning: unused variable `mreq'libavformat/udp.c: In function `udp_leave_multicast_group':libavformat/udp.c:206: error: storage size of 'mreq' isn't knownlibavformat/udp.c:206: warning: unused variable `mreq'gmake: *** [libavformat/udp.o] Error 1

Also I used your sugested configuration(./configure --prefix=/tmp --disable-protocol=udp,udplite && gmake) and compilation worked fine. I'm getting an error now when i try to install :bash-3.2# gmake installINSTALL install-progs-yesINSTALL ffmpegINSTALL ffprobeinstall: The -c, -f, -n options each require a directory following!gmake: *** [install-progs] Error 2

Regards Cristian
     În Joi, 5 Februarie 2015 11:21:18, Carl Eugen Hoyos <cehoyos at ag.or.at> a scris:

 Dustinta Cristian <dst_cristi_16-at-yahoo.ro <at> ffmpeg.org> writes:

> I used "--disable-pthreads"  because I'm getting 
> warnings like: gcc: unrecognized option `-pthread'

Please ignore the warnings, do not add --disable-pthreads!

> libavformat/udp.c: In function `udp_join_multicast_group':
> libavformat/udp.c:174: error: storage size of 'mreq' isn't known

I would like to understand this better:
Please run "./configure && make libavformat/udp.o", 
then run "make V=1 libavformat/udp.o" (twice) and 
provide the complete console output of the last run.
(Please do not post the output of all runs.)
What does "uname -a" show for you?
Consider attaching your "/usr/include/netinet/in.h" file.

> I tryed removing  --disable-mmx but same error.

If the option makes no difference, please remove it.

To fix compilation, please use:
$ ./configure --disable-protocol=udp,udplite && make

Your email is very difficult to read:
Consider fixing your email client.

Thank you for the report, Carl Eugen
ffmpeg-user mailing list
ffmpeg-user at ffmpeg.org


More information about the ffmpeg-user mailing list