[FFmpeg-user] IVTC with pullup filter

Nicholas Robbins nickrobbins at yahoo.com
Wed Feb 11 23:52:31 CET 2015

> On Wednesday, February 11, 2015 4:40 PM, marcjn <windbreiz at gmail.com> wrote:

> My mistake.  I can't believe I did that and overlooked it .  Thanks for
> looking at the sample.  The reason for the strange frame rate: I created
> that clip from a 29.97 fps telecined recording, and to be sure I had a
> constant 29.97 fps, I wrote -r 29000/1001 instead of 30000/1001.  I am
> adding a hopefully 'correct' 29.97 fps TermSample3.mp4 sample  here
> <https://dl.dropboxusercontent.com/u/71351606/TermSample3.mp4>  
> Now, using -vf pullup,fps=23.177 on the original sample still gives me 2
> progressive + 2 blended frames when runnning the command (see log  here
> <https://dl.dropboxusercontent.com/u/71351606/pullup_fps20.log>  )
> Using -vf pullup,fps=24000/1001 on the new 29.97 fps sample
> (TermSample3.mp4), I still get the same result (see log  here
> <https://dl.dropboxusercontent.com/u/71351606/pullup_fps3.log>  )
> I will look at mkv as well but it seems that my frame rate error doesn't

> explain the issue at this point. I can't reproduce the error. Leaving off the fps
> command, I get something that looks fine.


ffmpeg -i TermSample3.mp4 -vf pullup out.mkv

I compare the frames in the original that were not combed, they appear to be identical to the new one. I don't see the problems you are seeing.  The only problem is that this produces 24 fps material that claims to be 30 fps.

Adding in -r 24000/1001 fixes the 30fps claim. Now the material claims to be 24fps. Only 2 frames are dropped as a result of the -r output option.

-vf fieldmatch,decimateproduces material that looks identical to me. 

Could you double check that the orginal isn't blurred. Those amo belts or whatever he is swinging are blurred in the original because they are moving quickly.


More information about the ffmpeg-user mailing list