[FFmpeg-user] UDP streaming to Pico QAM modulator

Steve Kowald skowald at gvtc.com
Tue Jul 7 19:36:23 CEST 2015

Has anyone tried UDP streaming of a live capture source, such as a
BlackMagic card, encoded to mpeg2ts to  a Pico QAM IP modulator?

The modulator is reporting both PAT and PMT faults and will not play either
the audio or video stream .   I have tried both direct streaming

to the Pico address and to a multicast address without any luck.   If I use
multicast I can see the stream in ffplay and VLC.   I am able to stream

mpegts files to the QAM using LeadTools multi-media kit but I can't seem to
get their sample apps to work at all for live capture using a Blackmagic


I looked at some past posts that mention specifying pkt_size=1316 to prevent
fragmentation but this didn't seem to help.

I have tried all sorts of combinations on the command line, this is the last
thing I was trying:


ffmpeg -f decklink -i "DeckLink Mini Recorder (2)@9" -vcodec mpeg2video
-streamid 0:50 -streamid 1:52 -pix_fmt yuv420p -vb 15000000

-minrate 15000000 -maxrate 15000000 -bufsize 7500000 -r 29.97  -async 1
-acodec mp2 -ac 2 -ab 224k -ar 44100 -f mpegts

-mpegts_pmt_start_pid 0x1f00 -mpegts_start_pid 0x0f00  -mpegts_m2ts_mode 1



Any help is appreciated.

More information about the ffmpeg-user mailing list