[FFmpeg-user] Statics when record with ffmpeg

MrNice wxcvbn2006 at iol.ie
Sat Jul 11 09:30:12 CEST 2015


For few months, I have an issue when I record sound on my Linux fedora
22 desktop. I never got the fix but now I need it to be fixed, so here I am:

Hardware and software:
Motherboard ASRock 970 Extreme4
CPU AMD FX-8120 Eight-Core Processor
Fedora 22
ffmpeg version 2.6.3 Copyright (c) 2000-2015 the FFmpeg developers
built with gcc 5.1.1 (GCC) 20150422 (Red Hat 5.1.1-1)
configuration: --prefix=/usr --bindir=/usr/bin
--datadir=/usr/share/ffmpeg --incdir=/usr/include/ffmpeg
--libdir=/usr/lib64 --mandir=/usr/share/man --arch=x86_64
--optflags='-O2 -g -pipe -Wall -Werror=format-security
-Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong
--param=ssp-buffer-size=4 -grecord-gcc-switches -m64 -mtune=generic'
--enable-bzlib --disable-crystalhd --enable-frei0r --enable-gnutls
--enable-ladspa --enable-libass --enable-libcdio --enable-libdc1394
--disable-indev=jack --enable-libfreetype --enable-libgsm
--enable-libmp3lame --enable-openal --enable-libopencv
--enable-libopenjpeg --enable-libopus --enable-libpulse
--enable-libschroedinger --enable-libsoxr --enable-libspeex
--enable-libtheora --enable-libvorbis --enable-libv4l2 --enable-libvpx
--enable-libx264 --enable-libx265 --enable-libxvid --enable-x11grab
--enable-avfilter --enable-avresample --enable-postproc
--enable-pthreads --disable-static --enable-shared --enable-gpl
--disable-debug --disable-stripping --shlibdir=/usr/lib64
libavutil      54. 20.100 / 54. 20.100
libavcodec     56. 26.100 / 56. 26.100
libavformat    56. 25.101 / 56. 25.101
libavdevice    56.  4.100 / 56.  4.100
libavfilter     5. 11.102 /  5. 11.102
libavresample   2.  1.  0 /  2.  1.  0
libswscale      3.  1.101 /  3.  1.101
libswresample   1.  1.100 /  1.  1.100
libpostproc    53.  3.100 / 53.  3.100

The problem:
When I record with ffmpeg a sound from the Line in, I get statics just
after every sound impulsion. I have a mp3 file with "bip" every second
playing from a mp3 player connected to Line in. Command Line is:
ffmpeg -debug 1 -vn -f alsa -ac 2 -channel_layout stereo -i hw:0,0 -c:a
pcm_s16le /Store3/Test/pcm_`date +%m%d_%H%M`.wav

Same issue with ffplay:
ffplay -debug 1 -f alsa -ac 2 -i hw:0,0
Statics after almost every bip

Same issue with VLC (input hw:0,0),statics after every bip.

When I record and play with Audacity with Alsa, Recording device:
default then pulse then ALC892 (hw:0,0), sound is perfect.
When I record with gnome-sound-recorder 3.16.0-1.fc22, format flac, ogg,
sound is perfect.
When I record with arecord, CL: arecord -f cd -t wav out.wav, sound is

Something strange I noticed:
I start the player, then I run command ffmpeg.
After few seconds, music is playing, I stop ffmpeg (type q) then I stop
the player.(first file)
Then I run again ffmpeg (no music, no sound is playing), I wait few
seconds then I stop ffmpeg.(second file)
When I listen the first file, I have music with distortion/statics then
stop suddenly.(OK)
The I listen the second file (the second file should be only silence but
here is the most important): I can listen at the beginning around 1 full
second of the end of the previous recording with a lot of
distortion/statics. Looks like there is a recording memory overflow.

I have tried to adjust all the levels and can say for sure this is not
an over-level saturation issue.
When I listen directly from line in, sound is perfect.

I don't know what to do more.
Let me know a site to upload an audio file if you want a sample of the
Let me know any info you need to help me to get rid of this annoying

Many thanks for your help

More information about the ffmpeg-user mailing list