[FFmpeg-user] Could not write header for output file #0 (incorrect codec parameters ?)

MrNice wxcvbn2006 at iol.ie
Sun Jul 26 11:32:51 CEST 2015

On 25/07/15 16:21, Carl Eugen Hoyos wrote:
> MrNice <wxcvbn2006 <at> iol.ie> writes:
>> Input #0, pulse, from 'alsa_input.pci-0000_00_14.2.analog-stereo':
>>   Duration: N/A, start: 1437724175.042321
>> Input #1, video4linux2,v4l2, from '/dev/video0':
>>   Duration: N/A, start: 1349.084272
> This is a major issue, you may try options like 
> the following that may fix it:
> -ts abs
> -ts mono2abs
> -wallclock 0
> (And it is of course possible that this issue 
> disappears with alsa, I don't know...)
> Carl Eugen

Really I have no luck: For months I try to find fix for ffmpeg with
alsa, as I got statics in the audio. Ubuntu, Ubuntu studio, Mint,
Centos, Stella, Fedora, have the same issue (New OS install on a spare
HD for each of them).

This month, I found out that with pulse, audio is good. I was happy.

Now I have an error with Duration...
I tried -ts abs then -ts mono2abs, (wallclock is the same as abs)

Duration: N/A, start: 1437900701.356327
Duration: N/A, start: 1437900702.504357
Cliping frame in rate conversion by 0.000008
Cliping frame in rate conversion by 0.199486
Past duration 0.600685 too large

I even tried -force_key_frames 00:00:00.000 (found in another forum),
same issue.
Same issue with alsa (+ statics)

So, I am a bit hopeless, and it's raining again outside. :-(
I am sorry, I don't want to take advantage of your kindness, Carl,
Moritz, but I'll need your help again.

So, what do you want I do?

More information about the ffmpeg-user mailing list