[FFmpeg-user] Help recovering video of cherished moment

PAUL Kirchhoffer PKIRCHHOFFER at msn.com
Sat Dec 17 20:05:38 EET 2016

Dear ffmpeg user community,

I hope you will forgive my ignorance in this domain.  I'm can generally solve my own problems in the tech domain but this one has me stumped.

I have 4 very old .avi video files taken shortly after our youngest son's birth.  The videos are small and grainy but they capture a cherished event so I would love to recover them.  I've been floundering around trying to solve this problem on my own and have come to the realization that I need help.

Here's what I think I know about these files:

-          I've used media analysis software including ffprobe (thank you) to determine what codec was used to encode them

o   codec_type=video | codec_tag_string=VDO3 | codec_tag=0x334f4456

o   the remainder of an  ffprobe command I found on the web is in the attached avi.txt file along with a sample video

o   the codec was developed by a company that no longer exists - based on what I read, their technology was incorporated into NetShow Tools, then Direct Show, then Windows Media Player

If you are inclined to help and know how, perhaps all you need to is the sample video.  If you could use some comic relief in your life this holiday season, continue reading the short chronicle of my failures below.  Thanks in advance for any suggestions this group may have on how to proceed.

I've tried everything I know how to do and many things I have no clue how to do:

-          I found the original codec file using the wayback machine but couldn't install it in the Windows10 version of WMP

-          I tried unsuccessfully to set up a winXP media Center virtualbox but failed when I couldn't locate a copy of the operating system

-          I succeeded in installing WMP9 and WMP10 using wine on Ubunutu but learned my 32-bit codec wouldn't work on a 64-bit machine

-          I tried using ffmpeg on both Ubuntu and Windows but it looks like the codec is not yet supported

-          The MPlayer documentation indicated the codec was supported and I finally succeeded in getting Mplayer running on a 32-bit Ubuntu virtualbox.  I think I succeeded in getting Mplayer to use the correct codec but I got no video.  The videos have been copied to many different hard drives over the years - maybe they are corrupt.

Thanks to generosity and brilliance of others, I got much farther than I ever would have on my own, but am still coming up short.

Happy Holidays,
Paul Kirchhoffer

-------------- next part --------------
A non-text attachment was scrubbed...
Name: tjkfirstseconds.avi
Type: video/avi
Size: 145408 bytes
Desc: tjkfirstseconds.avi
URL: <http://ffmpeg.org/pipermail/ffmpeg-user/attachments/20161217/59339ed7/attachment.bin>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: avi.txt
URL: <http://ffmpeg.org/pipermail/ffmpeg-user/attachments/20161217/59339ed7/attachment.txt>

More information about the ffmpeg-user mailing list